A common problem in mathematics is to determine which quadrant a given point lies in. There are four quadrants, numbered from 1 to 4, as shown in the diagram below:
For example, the point A, which is at coordinates (12,5) lies in quadrant 1 since both its x and y values are positive, and point B lies in quadrant 2 since its x value is negative and its y value is positive.
Your job is to take a point and determine the quadrant it is in. You can assume that neither of the two coordinates will be 0.
Input
The first line of input contains the integer x (−1000≤x≤1000;x≠0). The second line of input contains the integer y (−1000≤y≤1000;y≠0).
Output
Output the quadrant number (1, 2, 3 or 4) for the point (x,y).
Sample Input 1Sample Output 1
Sample Input 2Sample Output 2
import java.util.*;
public class Quadrant {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int x = sc.nextInt();
int y = sc.nextInt();
if (x > 0 && y > 0){
System.out.println(1);
} else if (x < 0 && y > 0){
System.out.println(2);
} else if (x < 0 && y < 0){
System.out.println(3);
} else {
System.out.println(4);
}
}
}
'Algorithms and Data Structures > Coding Practices' 카테고리의 다른 글
LeetCode 121. Best Time to Buy and Sell Stock (0) | 2022.07.15 |
---|---|
Kattis What is greater? (0) | 2022.07.15 |
LeetCode LinkedList Cycle II (0) | 2022.07.15 |
AlgoExpert Product Sum (0) | 2022.07.15 |
AlgoExpert Fibonacci (0) | 2022.07.15 |